Skip to main content

版本说明 - v2.5.5

Rancher 2.5.5 版本于 2021 年 1 月 16 日发布。单击这里查看英文版版本说明。

Rancher v2.5.5 是 v2.5.4 的镜像版本,解决了一些小问题:

  • 如果 helm charts 缺少某些注释,仪表盘可能会崩溃。
  • rancher helm charts 被限制在 Kubernetes 版本小于 1.20.0 的情况下。增加这一限制是为了防止 Rancher 安装在不兼容的 Kubernetes 版本上。v2.5.5 charts 最初发布时没有这个限制。在 2020 年 12 月 1 日之前安装该 charts 的用户可能会在不支持的 Kubernetes 版本上遇到问题。 链接
  • Rancher 的集群浏览器现在只在 Windows 集群上显示 Windows 兼容的 Chart。
  • 增加了对 RKE2 集群升级到 Kubernetes v1.18.13 版本的支持。

重要说明#

自 2.0 版本以来,Rancher 中的主要 UI 是 Cluster Manager。我们在 Rancher 2.4 中实验性地发布新的 UI Cluster Explorer 仪表板,已经升级到 GA 状态。有一些新的功能只在新的 Cluster Explorer 仪表板中可用。这些新功能中的一些功能与 Cluster Manager 中的现有功能类似,我们将尝试根据它们在 UI 中的位置来区分它们。

安装和升级说明#

  • 由于最新的 cert-manager 版本的变化,Rancher 的安装或升级必须与 Helm 3.2.x+一起进行。
  • 在安装 Rancher 2.5 之前,Rancher HA 集群应该升级到 Kubernetes 1.17+。
  • 如果在离线安装的 Rancher 前使用代理,必须向 NO_PROXY 传递附加参数。
  • 不能再关闭本地集群,这意味着所有管理员都可以访问本地集群。如果你想限制本地集群的权限,必须使用一个新的集群角色:restricted-admin role。
  • 如果您正在使用 Rancher 管理其他 Rancher 实例,请不要在此时升级,因为围绕冲突的控制器存在已知问题。
  • 如果你正在运行 UI 的 forked 构建,并将 ui-index 设置为 local,目前无法强制加载。

Docker 安装#

  • 启动 Rancher Docker 容器时,必须使用特权标志。更多信息请参见离线单节点安装指南
  • 如果你在安装 Docker 时使用了自定义证书,集群就不能被配置。
  • 当在离线环境中安装时,你必须向 Docker 运行命令提供一个自定义 registries.yaml 文件,如 k3s 文档中所示。如果注册表有证书,那么你也需要提供。
  • 围绕启动时间的 UI 问题。

Cluster Manager 和 Cluster Explorer 中的重复功能#

  • 由于潜在的 CRD 冲突,任何时候只能安装 1 个版本的功能。
  • 每个功能只能由它所部署的用户界面来管理。
  • 如果您在 Cluster Manager 中安装了该功能,则必须在 Cluster Manager 中卸载,然后再尝试在 Cluster Explorer 仪表盘中安装新版本。

Kubernetes 1.19#

  • 对于 K8s 1.19 和更新的版本,我们建议禁用 firewalld,因为已经发现它与各种 CNI 插件不兼容。
  • 由于 Kubernetes 1.19 中的某些指标发生了变化,Cluster Manager 中的某些警报在 K8s 1.19 中无法使用。

已废弃的功能#

功能描述
Cluster Manager - Rancher 监控Cluster Manager UI 中的监控已被新的监控图所取代,该监控图可在 Cluster Explorer 中的 Apps & Marketplace 中使用。
Cluster Manager - Rancher 告警和通知告警和通知功能现在直接与集群资源管理器中的应用程序和市场中可用的新监控图集成。
Cluster Manager - Rancher 日志使用集群资源管理器中的应用程序和市场中可用的新的日志,用新的日志解决方案替换功能。
Cluster Manager - 多集群应用部署现在建议使用 Cluster Explorer 中可用的由 Fleet 支持的 Rancher 持续交付处理部署到多个集群。
Cluster Manager - Kubernetes CIS 1.4扫描 Kubernetes CIS 1.5+基准扫描现在被一个新的扫描工具所取代,该工具部署在 Cluster Explorer 中的应用程序和市场中的 cis 基准图。
luster Manager - Rancher 流水线基于 Git 的部署管道现在推荐使用 Cluster Explorer 中可用的由 Fleet 支持的 Rancher 持续交付来处理。
Cluster Manager - Istio v1.5Istio 项目已经结束对 Istio 1.5 的支持,并建议所有用户升级。Istio 1.7 现在可以在 Cluster Explorer 的 Apps & Marketplace 中作为 Istio Chart 使用。

版本#

下面的版本为当前的最新版和稳定版:

类型Rancher 版本Docker 标签Helm 仓库Helm Chart 版本
最新版v2.5.5rancher/rancher:latestserver-charts/latestv2.5.5
稳定版v2.5.5rancher/rancher:stableserver-charts/stablev2.5.5

自 v2.5.3 以来修复的主要问题#

  • 改用 xml-roundtrip-validator 包来解决 go 的 xml 包中的 xml 漏洞,相关 Issue
  • 修正了集群管理器监控下的间歇性安装失败,相关 Issue:#30188
  • 修正了加固集群上集群资源管理器监控安装错误,相关 Issue:#29980
  • 修正了通过 kubectl shell 执行到 pods 时的错误,相关 Issue:#29668
  • Rancher 现在支持使用 OpenLDAP 时的 startTLS,相关 Issue:#29153
  • 修正了集群管理器监控中找不到秘密 webhook-receiver 时的错误信息,相关 Issue:#28954
  • Rancher pods 在死节点上没有长期调度,相关 Issue:#27734
  • 运行 Amazon Linux 的节点不再无法供应,相关 Issue:#21648
  • 修正了集群管理器对具有 Windows Server SAC 1909 节点的集群和具有 Windows Server LTSC 2019 节点的集群的日志支持,相关 Issue:#30279
  • 修正了集群管理器监控的 prometheus 操作者容器启动错误与 nfs 子路径,相关 Issue:#29149

其他说明#

已知问题#

  • 如果在一个 PSP 的集群中启用了 sidecar 注入,且 FS 组被设置为 MustRunAs,范围为 1~1024,则 Istio 部署可能会失败。
  • 集群资源管理器日志可能无法捕获云提供商的所有 kubelet 日志。
  • 用自定义加密方式轮换加密密钥会失败。

Cluster Explorer 功能注意事项和升级#

  • 一般问题
    • 并非所有的新功能目前都可以安装在加固的集群上。
    • 新功能预计将使用 Helm3 CLI 而不是 Rancher CLI 进行部署。
    • 新的日志和监控功能还不能与 windows 集群一起使用。
    • 在集群配置过程中会断断续续的出现一个错误,在没有任何用户干预的情况下,几分钟内就会恢复。
  • Rancher 备份
    • 当迁移到具有 Rancher 备份功能的集群时,服务器-url 不能更改到不同的位置,必须继续使用相同的 URL。
    • Rancher 持续交付(Fleet)在备份期间不处理。备份#46
  • 监控
    • 在使用 Rancher 监控来监控使用 RancherOS 主机的集群中的 etcd 节点时,存在一个已知的问题#29815。如果您的 etcd 平面仅由 RancherOS 主机组成,可以在这里找到这个问题的解决方法。然而,对于在其 etcd 平面中混合使用 RancherOS 和非 RancherOS 主机的集群,没有现有的解决方法。
    • 为了继续支持使用 9.4.200 版本 Rancher 监控图的用户,Dashboard UI 设置的 k3s 集群的默认内存限制已经增加到 2500Mi。对于升级到 Chart 9.4.201 版本的用户来说,不需要这个增加的限制,但建议使用。
    • 监控有时会在安装时出错,因为它不能识别 CRD。
  • OPA Gatekeeper

改进和优化#

  • CIS v2 改进--调度和告警/警报,自定义基准。
  • CIS 1.6 for RKE1
  • CIS 1.5 for RKE2
  • Istio 改进--支持 CNI、Jaeger
  • Cluster Explorer 日志增强--Syslog 支持和 GKE/AKS 节点日志。
  • 现在可以按每个加载项配置容忍度,并应用于部署资源。配置的容忍将取代现有的容忍,因此请确保配置了所有需要的容忍。这解决了一个问题,即具有通配符容忍(容忍所有污点的容忍)的加载模块没有被驱逐,如果手动删除,可能会被调度到 NotReady 节点。为了避免升级时不可调度的 pod,默认配置将是相同的(所以与通配符容忍),因此您需要配置容忍以覆盖默认配置。请参阅文档了解更多信息。
  • RKE 加密密钥现在可以从 rancher API 中轮换。
  • 可以选择禁用默认的 nginx http 后台。它是默认安装的。
  • 仪表板支持配置额外的警报接收方式
  • 仪表板现在支持额外的日志输出
  • 在集群浏览器中用户界面改进

版本信息#

镜像#

  • rancher/rancher:v2.5.5
  • rancher/rancher-agent:v2.5.5

工具#

Kubernete 版本#

问题修复#

  • 修正了 CPU 和内存使用量增加的问题。
  • 减少了过多的"rejected by webhook"信息。
  • reset-admin url 不再是一个私有 ip。
  • 修正了配置 RKE 集群时的恐慌问题。
  • 解决了在运行 flatcar os 的节点上安装 RKE 时的错误。
  • 修正了创建托管的 EKS V2 集群与现有 EKS 集群名称相同时的错误。
  • 防止在使用 rancher 创建同名集群时,eks 中现有集群被更新。
  • 压制常量废弃日志。
  • 修正了启用警报时规则部署器的错误。
  • 修正了在安装 OPA 守门人 V2 后出现的错误。
  • 修正了供应 rke 集群时的 nil 指针错误。
  • 停止使用过时的网络资源。
  • 修正了安装时缺少入口的 RKE。
  • 修正从 rancher 2.5.2 升级时的问题。
  • 修正了删除当前正在配置的节点时的恐慌。
  • 重置密码不再引起恐慌。
  • EKSv2 现在可以与私有端点一起工作了,在 EKSv2 中删除了私有端点的额外网络配置的必要性
  • 在 images.txt 中添加了缺失的镜像。
  • 仪表盘错误修复
  • UI 修复

升级和回滚#

Rancher 支持升级和回滚两种方式。请注意您要升级或回滚的版本来更改 Rancher 版本。

请注意,升级到 v2.3.0+后,由于增加了对 Kubernetes 系统组件的容忍度,对 Rancher 启动的 Kubernetes 集群的任何编辑都会导致所有系统组件重启。据此进行规划。

最近对 cert-manager 的更改需要升级,如果您有使用自签名证书的 Rancher 的 HA 安装。如果您使用的 cert-manager 比 v0.9.1 旧,请查看关于如何升级 cert-manager 的文档。

重要:当回滚时,我们希望您回滚到升级时的状态。任何升级后的变化都不会被反映出来。

Assets#

请在这里获取该版本的 Assets。

Last updated on by yzeng25