Skip to main content

版本说明 - v2.4.15

Rancher 2.4.15 版本于 2021 年 3 月 13 日发布。单击这里查看英文版版本说明。

Rancher v2.4.15 是 v2.4.14 的镜像版本,解决了一个问题。

当使用未进行身份验证的私有注册表时,使用基础设施提供商的节点创建的 RKE 集群的配置或更新将失败。#31600

重要说明#

  • CVE-2021-25313:当使用浏览器访问 Rancher API 时,URL 没有被正确地转义,使其容易受到 XSS 攻击。到这些 API 端点的特别制作的 URL 可能包括 JavaScript,这些 JavaScript 将被嵌入到页面中并在浏览器中执行。没有直接的缓解措施。避免单击不受信任的链接到您的 Rancher server。#31583

  • 请阅读v2.4.0 版本说明中的重要更新和重大改动的说明

  • Kubernetes 1.18 现在为默认版本 [#25117]: Kubernetes 1.18 现在为默认版本。在任何时候升级 Kubernetes 版本之前,请阅读 Kubernetes 的版本说明,来了解重要变更。

  • 使用单节点 Docker 安装的用户请注意: Docker 容器中的 Etcd 已从 3.3 升级到了 3.4,因此,您必须在升级之前进行备份,以便能够回滚到 v2.3.x 版本。没有此备份,将无法回滚。

  • 使用节点池功能,并使用 RHEL/CentOS 的用户请注意 [#18065]: RHEL / CentOS 节点的默认存储驱动已更新为overlay2。如果您的节点模板未指定存储驱动,则在使用该模版创建新节点时,将使用默认值overlay2而不是之前的devicemapper作为存储驱动。如果您需要继续使用devicemapper作为存储驱动选项,请编辑节点模板,并将存储驱动显式设置为 devicemapper

  • 使用 Windows 集群的用户请注意 [#25582]: Windows 已于 2 月 11 日发布了安全补丁程序。升级之前,请更新您的节点以包括此安全补丁程序,否则,升级将失败,直到您使用该补丁程序为止。

  • Rancher 部署的集群(RKE 集群)需要额外的 500MB 磁盘空间 Rancher 部署的集群(RKE 集群)默认开启了审计日志功能。

  • Rancher 部署的集群(RKE 集群)升级方式发生了变化 [#23897]: 请参考零宕机升级功能以了解更多信息。

  • 将 Rancher Helm Chart 中的 Kubernetes 版本限制为小于 v1.20.0 的版本#30746,添加此限制是为了防止 Rancher 安装在不兼容的 Kubernetes 版本上。

版本#

下面的版本为当前的最新版和稳定版:

类型Rancher 版本Docker 标签Helm 仓库Helm Chart 版本
最新版v2.5.6rancher/rancher:latestserver-charts/latestv2.5.6
稳定版v2.5.6rancher/rancher:stableserver-charts/stablev2.5.6

自 2.4.13 以来修复的问题#

主要问题#

  • 修正了一个 RKE 集群在有 Cordoned worker 节点并开始移除主节点时卡住的问题。#31271
  • 修正了一个对 Windows 服务器核心节点的监控失效的问题。#31141
  • 修正了遥测客户端出现套接字泄漏并导致升级问题或 k8s 问题的问题。#28360

离线安装和升级#

在 v2.4.0 的版本里,离线安装将不在需要手动同步 system charts 的源代码仓库了。具体操作请参阅有关安装 Rancher 时,如何使用内嵌的 system charts

已知问题#

  • 当使用监控并启用 Grafana 的持久性存储时,升级监控会导致 pod 无法启动。问题中提供了解决步骤。#27450
  • 使用监控时,升级 Kubernetes 版本会移除 "API Server Request Rate"指标。#27267
  • 当 Helm3 应用商店中添加新的 Helm Chart 版本时,升级过程中可能会默认为 Helm3,导致 api 错误。请参考27252解决这个问题。

版本信息#

镜像#

rancher/rancher:v2.4.15 rancher/rancher-agent:v2.4.15

工具#

Kubernete 版本#

升级和回滚#

Rancher 支持升级回滚操作。在修改 Rancher 版本时,请先确认您要升级到或者回滚到的 Rancher 版本。

请注意,在升级到 v2.3.0 或者以上版本时,第一次修改通过 Rancher v2.3.0 之前版本部署的 RKE 集群时,由于要向系统组件中加入 Tolerations,该集群全部的系统组件将会自动重启。请事先规划好。

如果您的 Rancher HA 在使用 低于 v0.9.1 的 cert-manager,并且是自签名证书,由于 cert-manager 最新的变化,您需要升级 cert-manager 的版本。具体操作请参阅有关如何升级 cert-manager的文档。

重要:回滚时,我们建议回滚至升级前的状态,Rancher 不会保留回滚前的修改。

Assets#

请在这里获取该版本的 Assets。

Last updated on by yzeng25