版本说明 - v2.3.1

Rancher 2.3.1 版本于 2019 年 10 月 17 日发布。本文介绍了 Rancher 2.3.1 相较上一版本(2.3.0)的重大改动、新增的实验性功能、已修复的问题和已知问题。点击这里查看英文版版本说明。

重要说明

  • 如果您打算从 v2.2 版本升级到该版本,请务必查看v2.3.0 版本说明中的重要更新和重大改动的说明。

  • 这次发布带来了最新的 Kubernetes 版本,例如 v1.13.12,v1.14.8,v1.15.5。您可以通过这些版本升级您通过 Rancher 部署的集群。这些版本是为了修复 Kubernetes 的安全漏洞CVE-2019-11253CVE-2019-16276。我们建议您把全部的 Kubernetes 集群都升级到这些版本。

  • 如果您通过 LetsEncrypt 的方式启动了单节点的 Rancher Server,您必须要升级到这个版本,这样您才可以通过 LetsEncrypt 更新您的证书。LetsEncrypt 正在 弃用 V1 API Endpoints 并且将在 11 月 1 日正式生效。

  • 如果您的 Rancher HA 在使用 低于 v0.9.1 的 cert-manager,并且是自签名证书,由于 cert-manager 最新的变化,您需要升级 cert-manager 的版本。具体操作请参阅有关如何升级 cert-manager的文档。

下面的版本为当前的最新版和稳定版:

类型Rancher 版本Docker 标签Helm 仓库Helm Chart 版本
最新版v2.3.1rancher/rancher:latestserver-charts/latestv2.3.1
稳定版v2.2.9rancher/rancher:stableserver-charts/stablev2.2.9

您可以通过如何选择版本的文档,了解更多关于不同版本和标签的区别。

实验性功能

我们提供了一种启停 Rancher 中实验性功能模块的能力。在这个版本里,您需要通过 API 来控制“功能开关”。详情请查阅在 Rancher 中如何开启某些功能的文档。

自 v2.3.0 以来修复的主要问题

  • 修复了一个使用 LetsEncrypt 证书的单节点 Rancher 无法正常工作的问题,这是由于引用了 v1 API 导致的 [#23365]
  • 修复 jailer 脚本运行超时导致的问题,并且支持配置 jailer 超时的参数 [#22379, #23160]
  • 修复了一个在 RKE 集群模板中 k8s 没有被正确处理和展示的问题 [#23360, #23359, 23361]
  • 修复了一个 RKE 模板在某些 k8s 版本下无法激活 Windows 支持的问题 [#23395]
  • 修复了一个无法将 RKE 集群通过 RKE 模板更新的问题 #23383]
  • 修复了一个单节点 Rancher Server 在挂载了主机目录后无法使用内嵌 system charts 的问题 [#23427]
  • 更新 Rancher 和 RKE 中使用的 yaml 库到 v2.2.4 版本,来修复CVE-2019-11253

其他说明

离线安装和升级

在 v2.3.0+的版本里,离线安装将不在需要手动同步 system charts 的源代码仓库了。具体操作请参阅有关安装 Rancher 时,如何使用内嵌的 system charts

主要的已知问题

  • Windows 集群限制 - 由于其他上游依赖的原因,Windows 集群有一些已知的限制:

    • 在使用 Flannel VXLAN (Overlay) 模式时, Windows Pods 无法访问 Kubernetes API。临时解决方案是使用 Flannel Host Gateway (L2bridge)模式。该问题将在 k8s 1.18 版本中修复。[#20968]

    • Windows 集群的日志功能仅在 Flannel Host Gateway (L2bridge)模式下可以使用。该问题将在 k8s 1.18 版本中修复。[#20510]

  • Istio 限制 - Istio 无法在使用受限的 Pod 安全策略的集群中激活 [#22469]

  • HPA 限制 - 因为 GKE 不支持 v2beta2.autoscaling 版本的 API。所以在 Rancher UI 中无法通过 UI 管理 GKE 集群的 HPA 资源。[#22292]

  • 安全加固限制 - 如果您按照 Rancher 的安全加固手册进行了配置,那么您将会遇到一些已知的问题。

    • 监控将无法工作 [#20884]
    • Rancher UI 中的 kubectl 将无法工作 [#19439]
    • 流水线将无法工作 [#22844]
  • 如果您是从 v2.2 升级上来的环境,在向已有节点模版中添加的 Taints 后,并使用这个节点模版来扩容 Worker 节点,那么这些新的 Worker 节点可能无法正常工作。您必须在对管理节点或 etcd 节点进行扩缩容后,或是对集群进行编辑后,这些带有 Taints 的新 Worker 节点才能正常工作。因为只有在集群 Reconcile 被触发后,系统组件才会自动添加 Tolerations [#22672]

  • 在升级 Rancher 版本后,集群告警组件或集群日志组件有可能会卡在 Updating 状态。临时解决方案可以在这个 issue 中找到。[#21480]

  • 如果您的 Rancher Server 所在的集群配置了 OpenStack cloud provider 并设置了 LoadBalancer,并且这个 Rancher Server 所在的集群是在 v2.2.3 或者更早的版本创建的,那么直接升级到 Rancher v2.2.4 或之后的版本将会失败。您可以在这个 issue 的评论中找到这种情况下的迁移方法 [#20699]

版本信息

镜像

  • rancher/rancher:v2.3.1
  • rancher/rancher-agent:v2.3.1

工具

Kubernetes 版本

注:在 v2.3.0+版本中,在有新的 Kubernetes 版本可用时,即使不升级 Rancher 版本,我们也会自动向您推送这些版本。所以您在 Rancher UI 中看到的可用版本,可能会高于如下版本。

升级和回滚

Rancher 支持升级回滚操作。在修改 Rancher 版本时,请先确认您要升级到或者回滚到的 Rancher 版本。

请注意,在升级到 v2.3.0 或者以上版本时,第一次修改通过 Rancher v2.3.0 之前版本部署的 RKE 集群时,由于要向系统组件中加入 Tolerations,该集群全部的系统组件将会自动重启。请事先规划好。

如果您的 Rancher HA 在使用 低于 v0.9.1 的 cert-manager,并且是自签名证书,由于 cert-manager 最新的变化,您需要升级 cert-manager 的版本。具体操作请参阅有关如何升级 cert-manager的文档。

重要

在回滚的时候,您将会被回滚到升级之前的状态。任何在升级后进行的改动将无法被保留。

Assets

请在这里获取该版本的 Assets。

最后由 yzeng25更新 于