版本说明 - v2.4.2

提示

Rancher 在发布 v2.4.1 版本时遇到了构建问题,所以我们跳过了 v2.4.1 ,直接发布了 v2.4.2 版本。

使用默认 TLS 的单节点 Docker 安装的用户请注意:您的 UI 可能无法加载,请使用这个临时解决方法来解决这个问题。

Rancher 2.4.2 版本于 2020 年 4 月 2 日发布。本文介绍了 Rancher 2.4.2 相较上一版本(2.4.0)的重大改动、新增的实验性功能、已修复的问题和已知问题。点击这里查看英文版版本说明。

重要说明

  • 请阅读v2.4.0 版本说明中的重要更新和重大改动的说明

  • 使用单节点 Docker 安装的用户请注意: - Docker 容器中的 Etcd 已从 3.3 升级到了 3.4,因此,您必须在升级之前进行备份,以便能够回滚到 v2.3.x 版本。没有此备份,将无法回滚。

  • 使用节点池功能,并使用 RHEL/CentOS 的用户请注意 [#18065]: RHEL / CentOS 节点的默认存储驱动已更新为overlay2。如果您的节点模板未指定存储驱动,则在使用该模版创建新节点时,将使用默认值overlay2而不是之前的devicemapper作为存储驱动。如果您需要继续使用devicemapper作为存储驱动选项,请编辑节点模板,并将存储驱动显式设置为 devicemapper

  • 使用 Windows 集群的用户请注意 [#25582]: - Windows 已于 2 月 11 日发布了安全补丁程序。升级之前,请更新您的节点以包括此安全补丁程序,否则,升级将失败,直到您使用该补丁程序为止。

  • Rancher 部署的集群(RKE 集群)需要额外的 500MB 磁盘空间 - Rancher 部署的集群(RKE 集群)默认开启了审计日志功能。

  • Rancher 部署的集群(RKE 集群)升级方式发生了变化 [#23897]: - 请参考零宕机升级功能以了解更多信息。

版本

下面的版本为当前的最新版和稳定版:

类型Rancher 版本Docker 标签Helm 仓库Helm Chart 版本
最新版v2.4.2rancher/rancher:latestserver-charts/latestv2.4.2
稳定版v2.3.6rancher/rancher:stableserver-charts/stablev2.3.6

您可以通过如何选择版本的文档,了解更多关于不同版本和标签的区别。

实验性功能

实验性功能的功能开关

我们提供了一种启停 Rancher 中实验性功能模块的能力。在这个版本里,您可以通过 UI 来控制“功能开关”。有些功能开关的调整会导致 Rancher Server 重启,详情请查阅在 Rancher 中如何开启某些功能的文档。

功能开关功能开关名称默认值可用版本是否需要重启 Rancher?
下一代 UIdashboardtruev2.4.2
新 Proxyproxyfalsev2.4.2
在 UI 中启用非默认激活的存储驱动(例如:Ceph)unsupported-storage-driversfalsev2.3.0

自 v2.4.0 以来修复的主要问题

  • 修复了 kubelet 可能不断重新启动的问题 [#26399]
  • 修复了项目所有者无法在 UI 中看到具有大写字母(例如 PVC,configMap,statefulSet)的 Kubernetes 资源的问题 [#26416]
  • 修复了在使用非默认端口暴露 Ingress 时无法登录 Rancher UI 的问题 [#26422]

其他说明

离线安装和升级

在 v2.4.2 的版本里,离线安装将不在需要手动同步 system charts 的源代码仓库了。具体操作请参阅有关安装 Rancher 时,如何使用内嵌的 system charts

主要的已知问题

  • 回滚了为了修复从 UI 删除节点后无法重新加入节点的问题的改动 [#23254]
  • 在下游集群升级期间,在上一个节点仍未完成时,便开始对下一个节点进行驱散 [#26401]
  • 在下游集群升级期间,如果集群中有任何 PodDisruptionBudgets,则驱散过程可能会停滞 [#26400]
  • 当集群中的节点断电时,Metrics Server Pod 和 CoreDNS Pod 可能不会从节点中移出,需要手动删除,才能将其重新调度到可用节点 [#26190#26191]
  • 某些情况下,即使已完成升级集群,单节点的 k3s 集群仍然显示Upgrading状态 [#26286]
  • 日志功能在导入的 k3s 集群中不能正常工作 [#24157]

版本信息

镜像

  • rancher/rancher:v2.4.2
  • rancher/rancher-agent:v2.4.2

工具

Kubernetes 版本

注:在 v2.3.0+版本中,在有新的 Kubernetes 版本可用时,即使不升级 Rancher 版本,我们也会自动向您推送这些版本。所以您在 Rancher UI 中看到的可用版本,可能会高于如下版本。

升级和回滚

Rancher 支持升级回滚操作。在修改 Rancher 版本时,请先确认您要升级到或者回滚到的 Rancher 版本。

请注意,在升级到 v2.3.0 或者以上版本时,第一次修改通过 Rancher v2.3.0 之前版本部署的 RKE 集群时,由于要向系统组件中加入 Tolerations,该集群全部的系统组件将会自动重启。请事先规划好。

如果您的 Rancher HA 在使用 低于 v0.9.1 的 cert-manager,并且是自签名证书,由于 cert-manager 最新的变化,您需要升级 cert-manager 的版本。具体操作请参阅有关如何升级 cert-manager的文档。

重要

在回滚的时候,您将会被回滚到升级之前的状态。任何在升级后进行的改动将无法被保留。

Assets

请在这里获取该版本的 Assets。

最后由 loganhz更新 于